CRM System Outage

Incident Report for intelliflo

Update

We continue to work with our service provider to investigate and resolve the ongoing service disruption.

As some customers may be experiencing issues accessing support contact channels, we ask that all support queries are temporarily sent to asksupport@intelliflo.com until further notice.

Our teams will monitor this mailbox and respond to enquiries as quickly as possible. We apologise for the inconvenience and will provide a further update as soon as additional information becomes available.
Posted Sep 16, 2026 - 11:46 BST

Update

We have identified that some customers are currently unable to access intelliflo Connect and may therefore be unable to submit new support cases.

Our teams are actively investigating this issue in relation to the wider service disruption.

We apologise for the inconvenience and thank you for your patience.
Posted Sep 16, 2026 - 10:55 BST

Update

We are continuing to investigate the cause of this issue with our service provider.
Posted Sep 16, 2026 - 10:13 BST

Update

While service availability has improved, we are continuing to see intermittent issues affecting our contact channels. Our teams remain engaged with the service provider and are actively monitoring the situation while investigations continue.
Posted Sep 16, 2026 - 09:58 BST

Update

We are now able to access our case logging CRM system, and inbound call and live chat services have been restored.

At this time, the incident remains under investigation and has not yet been confirmed as fully resolved. We are actively monitoring the service to ensure stability.

Thank you for your patience and understanding while we work to confirm full resolution.
Posted Sep 16, 2026 - 09:44 BST

Investigating

We are currently unable to access our case logging CRM system. As a result, our support team is unable to access inbound call and live chat services.

If you require support, please submit a case through intelliflo connect instead of contacting us via phone or live chat. We will review and action all submitted cases as soon as service is restored.

Our internal teams are investigating the issue and working to restore service as quickly as possible.
Posted Sep 16, 2026 - 09:21 BST
This incident affects: United Kingdom (⚙️ Core services).