22-03-2024 - Unable to access intelliflo office
Incident Report for intelliflo
Resolved
Great news - this issue has now been fully resolved. Sorry once again for the interruption to your day's work, and thanks for your patience.
Posted Mar 22, 2024 - 16:54 GMT
Monitoring
Our technical teams have been alerted to an issue that may have prevented some customers from accessing their intelliflo office accounts or degraded performance whilst navigating around.

However, delighted to say that this issue was for a brief period from 14:20 to 14:35GMT. The development team will continue to monitor this before closing the incident.

Sorry for any inconvenience caused as a result.
Posted Mar 22, 2024 - 14:40 GMT
This incident affected: United Kingdom (⚙️ Core services).