22-03-2024 - Live Chat Service for Customer support team
Incident Report for intelliflo
Resolved
Our third-party provider has confirmed that this incident is fully resolved, and our customer support team can now take Live Chats once more.

Thank you again for your patience.
Posted Mar 22, 2024 - 16:02 GMT
Investigating
Our third-party provider has encountered technical difficulties, which are impacting our Live Chat service and this may mean you can't connect to the team.

Should you need help from our customer support team, please raise a case via intellifo connect (which you can access through intelliflo office, using the intelliflo connect & Support button). Alternatively, you can also call our support team on 0330 102 8400


We'll let you know once this issue has been resolved. Thank you for your patience.
Posted Mar 22, 2024 - 14:21 GMT
This incident affected: United Kingdom (⚙️ Core services) and Australia (⚙️ Core services).